We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 16:15 CET
Update
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 14:11 CET
Identified
We are seeing services recover, but customers may continue to observe higher-than-normal error rates as cloudflare continue remediation efforts.
Posted Nov 18, 2025 - 13:54 CET
Investigating
Cloudflare is experiencing an internal service degradation. Some services may be intermittently impacted. We are focused on restoring service. We will update as we are able to remediate. More updates to follow shortly.