Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2026 - 13:31 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2026 - 13:17 CEST
Scheduled
We will be performing security updates and a Plesk platform update on our web hosting environment.
Expected impact: - Websites and email will remain available for the majority of the window. - The Plesk control panel will be unavailable for short periods. - A brief interruption to websites and email is possible while services restart.
No action is required on your side. We will update this page once maintenance is complete.
Thank you for your patience.
Posted Sep 04, 2026 - 13:16 CEST
This scheduled maintenance affected: Produkte (Webspace).